LABORATORY

검색 :
RSS 구독 : 글 / 댓글 / 트랙백 / 글+트랙백

글 검색 결과

ccna
글 10개

CCNA카테고리 관련.

2008/03/20 22:42, 글쓴이 prizm
[adsense1]
현재 블로그 저작툴(?)을 알아보는 중입니다..

windows live writer정도로 할까 생각중인데..
생각보다 마음에 들지 않군요..

문서로 만든 다음에 긁어서 붙여넣어야 할것 같습니다..

너무 오래 비워뒀군요..

필요하신분도 계실텐데..


[adsense2]
크리에이티브 커먼즈 라이센스
Creative Commons License
2008/03/20 22:42 2008/03/20 22:42

맨 위로

CCNA자격증 도착!

2008/03/15 12:37, 글쓴이 prizm
[adsense1]


2월 23일에 합격한 CCNA에 대한 자격증이 도착했습니다.ㅠㅠ;;

조금 험하게 오긴 했지만..
자격증은 자격증입니다!

인증샷 올라가요..

저런식으로 옵니다.. 아래에 찢어진건.. 배송중에 그런것 같아요..
우편배송으로 왔거든요..

스캔이 조금 이쁘지 않게 되었네요..
자격증 원본입니다.
하염없이 좋더군요!

동봉되어 있는 CISCO Systems CEO John Chambers씨의 서신입니다..
인쇄되어서 주는거라지만.. 그래도 기쁘군요!
사용자 삽입 이미지
사용자 삽입 이미지
신기한건 위에서처럼 플라스틱 카드 형태의 자격증도 준다는것입니다..

어쨋든.. 기뻐요~~


----------------
항상 느끼는 거지만, 자격증이 없어도 자격을 패스했으면 자격이 주어지는 것인데..
의외로 자격증을 받아야 뭔가 한것 같다는 느낌이 드는군요..

항상 그랬어요..
운전면허는.. 도봉면허시험장에 가서 3시간짜리 수업을 들을때 실감했답니다...

암턴.. CCNP도 열심히 공부해야겠네요..
너무 어렵긴 하지만.ㅡㅠ;;

[adsense2]
크리에이티브 커먼즈 라이센스
Creative Commons License
2008/03/15 12:37 2008/03/15 12:37

맨 위로

4. 기본이론..

2008/03/06 21:14, 글쓴이 prizm
[adsense1]
기본이론입니다..
이것또한 제가 썼던 학원 교재와 비슷한 차례대로 나갈텐데요.
중요한건 수업시간에 책 대신 강사님이 말로써 설명해 주신걸 제가 받아적은것을 기초로 합니다.
뭐.. 퍼가시면서 저작권이니 어쩌니.. 베꼈으면 베꼇다고 하라느니.. 그런소리 듣기 싫어서 밝히는 것입니다.
http://www.springnote.com를 써서 내용을 다 저장해놨으니.. 거기에 있는걸 그대로 복사해서 쓸지도 모르겠군요.
-----------------------------------------------------------------------------------
기본이론이라고 해봤자.. 네트워크가 기본적으로 동작할때 필요한 프로토콜들과 OSI7계층설명..
그리고 제일 중요한 IP기본이론과 서브넷팅, VLSM과 같은 IP대역쪼개기 기술이네요..
여기서는 아마도 기본 프로토콜까지 하지 않을까 합니다.

1. 네트워크란?
 - 특정 정보(데이터)를 보다 쉽게 공유하기 위해서 컴퓨터끼리 연결되어 형성된 조직 및 망(net).
 - 네트워크 확장에 따른 효율적인 관리를 위해서 프로토콜(Protocol)이라는 규약이 필요.
 - NIC(Network Interface Card, 일명 LAN카드)를 통해서 동작

2. 네트워크 유형
 1) LAN(Local Area Network)
   - LAN장비들이 비교적 작은 지역 단위로 연결된 네트워크 환경.
   - LNA장비 : LAN케이블, 허브, 브릿지, 스위치, NIC카드 등등
   - LAN프로토콜 : TCP/IP프로토콜은 필요가 없다.
       1. Ethernet(이더넷) : 전세계 90%가 사용하는 프로토콜. NIC카드로 동작된다. FastEthernet, GigabitEthernet도 이더넷이다.
       2. Token Rihg :  IBM에서 사용. 대중화는 되지 않았다.
       3. FDDI
   - 비용 : 높은 초기투자비용, 낮은 유지보수비용
   - 관리 : 사내 관리자/엔지니어. 문서화 관리.
 2) WAN(Wide Area Network)
   - LAN과 LAN을 연결하는 광역 네트워크 환경
       1. LAN케이블은 최대 100미터가 한계이다.
       2. 일반적으로 라우터같은 장비를 이용한다.
       3. ISP에서 서비스망을 임대한다.
       4. 서비스라고 한다. <-- 임대하기 때문에
   - WAN장비 : 라우터, WAN교환기, 스위치
   - WAN프로토콜 : HDLC, PPP, Frame-Relay, BGP등등. --> 대부분 HDLC프로토콜 이용
   - 비용 : 낮은 초기투자비용, 높은 유지보수비용 --> 서비스를 이용한은 것이다.
3) 인터넷
   - 수많은 LAN과 WAN이 연결된 통신망의 집합
   - TCP/IP프로토콜 이용.
   - 장점 : 다른기종, 다른 시스템간의 통신이 가능하다. <- 리눅스에서도 TCP/IP를 이요하고 윈도에서도 TCP/IP를 이용한다.
   - 단점 : 보안유지

3. 데이터 전송과정
  데이터 전송은 서버(Server)/클라이언트(Client) 관계에서 시작된다.
  1. 클라이언트가 서버에세 요청을 실시하며, 서버는 요청에 대해서 클라이언트에게 데이터 전송을 실시한다.  <-- 중요
  2. 데이터 전송시 출발지 주소/목적지 주소 정보가 명확해야 한다.
    • ex) A PC(client)-----------------------------------------파일서버(서버)

      IP 주소 : 192.168.1.10                                                        192.168.1.251

      포트번호 : 4766                                                                 80

      MAC 주소 : 0011.24fe.8f04                                                000c.28ab.780b

      1. 클라이언트가 서버에게 요청을 실시할때

        출발지 IP주소 : 192.168.1.10

        목적지 IP주소 : 192.168.1.251

        출발지 MAC주소 : 0011.24fe.8f04

        목적지 MAC주소 : 000c.28ab.780b

        출발지 포트번호 : 4766

        목적지 포트번호 : 80

      2. 서버가 클라이언트에게 데이터를 전송할때

        출발지 IP주소 : 192.168.1.251

        목적지 IP주소 : 192.168.1.10

        출발지 MAC주소 : 000c.28ab.780b

        목적지 MAC주소 : 0011.24fe.8f04

        출발지 포트번호 : 80

        목적지 포트번호 : 4766

참고 : 데이터 전송과정은 유니캐스트의 경우입니다. 1:1로 서버와 통신할때를 예로 든 것입니다. 실제로는 broadcast, multicast가 더 있습니다.. 또한 라우터를 거치게 되면 mac주소보다는 IP주소를 더 이용하게 되지요. 그냥 개념을 잡기위해서 Copy and Paste를 한 것입니다. 헤더에는 당연히 포트번호도 들어가겠지요??


----
여기까지 하겠습니다.

후기
인터넷을 검색해 보시면 더 많은 자료가 있을 것입니다.. 그리고 이론설명을 들을때 강사님이 윈도서버에서는 않되는것이 라우터에서는 된다고 하더군요.. 그게 아마도 ARP에 관련된게 아닐까 합니다.

그냥 무작정 Copy and Paste를 할 수도 있습니다만. 성의가 없잖아요.. 하나하나 다시 쓰려니 귀찮습니다. 요즘따라 운동을 해야한다는 것이 머리속에 꽉 차있는지라. 체력적인 한계까지 운동을 하게 되더군요..

저도 ccna에 대해서 인터넷이 찾아봤는데. Boson Netsim인가 하는 것으로 시뮬레이팅을 해서 조금 더 복잡한 라우팅을 보여주시는 분들도 계시더군요.. 뭐, 저도 하라고만 하면 할수는 있습니다만.. Dynamips가 아니라 조금 더 화끈하게 놀아보실분은 Netsim으로 하시는분의 자료를 보도록 하세요.. 그러나, 어짜피 CCNA에서는 거의 정해져있으니.. 그냥 기본이론과 커맨드만 알아가시면 어디서든지 사용하실수 있습니다..


생각같아서는 우분투를 깔아보는걸 해볼까... 합니다만.. 제대로 다루지도 못하면서 한다는것도 조금 우습구요.. 리눅스라는놈이 삽질에 삽질을 삽질해야 득도의 경지에 오른다고 하더군요.. 아직 그렇게까지 하고싶지는 않습니다만.. 모르죠.. 사람의 마음이란게..


CCNP수업을 듣고 있습니다. 혹시나 CCNP까지 도전하실분들은, CCNA공부. 열심히하세요. 덤프는 마지막에 풀어보시고, 책보면서 이론공부 하시구요.. 실습 충분히 해보시구요. CCNP의 내용이 CCNA를 기반으로 하는지라, CCNA내용을 모르면 낭패입니다.


...
더불어, 어떤분께서 리퍼러등급이 위에서 손꼽힐정도의 블로그가 제 블로그라고 하시던데요..
무슨말일까요???///
크리에이티브 커먼즈 라이센스
Creative Commons License
2008/03/06 21:14 2008/03/06 21:14

맨 위로

3. Static Route설정.

2008/03/03 20:18, 글쓴이 prizm
[adsense1]

세번째군요..
자주 올리려고 하는데 그놈의 귀차니즘때문에..

이번엔 Static Route를 해보도록 하지요.
실제로 CCNA에서 하는건 대부분 Layer3계층 프로토콜을 다루지요..
스위치는 Layer2계층이긴 하지만, L3인 경우 Layer3계층장비라고도 합니다..(라고 하더군요.)

라우터에서 설정해주는건 다른것이 아니고,
데이터의 경로를 가장 효율적으로 지정할수 있는..
혹은, 데이터를 가장 효율적으로 목적지까지 전송(혹은 중간에서 중계)할수 있는 프로토콜을 선택해서.
그에 해당하는 몇가지 설정
을 끄적이는 것이지요..

저는 Dynamips로 라우터 3개를 가지고몇개 안되는 네트워크를 다루게 되지만,
실제로는 엄청나게 많은 네트워크를 주무르는 것이지요.

아시는분들은 아시겠지만, 인터넷이라는 구조는 한곳의 경로가 끊기더라도 대체경로가 항상 존재하게 되지요.
만약, 대체경로까지 끊겼다면.. 그것은 대륙간의 해저 광케이블이 끊기거나 한 것입니다..

인터넷에서는 언제 어디서나 항상 대체경로는 존재하게 됩니다..
아니, 항상 대체경로는 존재하게 됩니다.. 정상적인 상황이라는 가정을 하면 말이죠.
Full Mesh라고 하나요?? 모든 노드에 대해서 모든 방향으로 이어져있는 구조.
이 구조가 인터넷이라고 보시면 될것 같네요..
뭐, 대강 알고 있는 것이라 진짜 전문가가 태클들어오면 저도 할말은 없습니다만..
틀린것은 거의 없다고 생각됩니다.

라우터에서는 네트워크의 물리적인 단절에 대해서 새로운 대체 경로를 신속하게 설정해야 합니다.
실제로 제가 168.126.63.1의 주소로 핑을 날리면(실제로 하지는 마세요.. 대한민국 DNS서버입니다..)
여러대의 네트워크를 거쳐서 목적지에 핑이 도달한 다음, 목적지 컴퓨터(라우터도 마찬가지입니다.)가 reply를 날려줍니다.. 이때, 중간에 회선이 단절되었으면 조금 돌아가더라도 다른 경로를 택하게 된답니다.

윈도우에서는 [tracert]명령어로 목적지까지 가는 경로를 볼수 있습니다.
이 명령으로 나오는 각각의 주소는 서버나 라우터를 의미합니다. 그리고 이때에도 중간에 경로가 단절되면 다른 대체경로를 택합니다.
위 그림에서, 각 주소를 홉(HOP)이라고 합니다.. 라우팅 프로토콜에서 최적경로 산출법중에 하나인 Distance Vector(Advanced Distance Vector)알고리즘이 HOP의 갯수를 인자로써 사용하지요..
(수정사항입니다.. HOP카운트는 Distance Vector 알고리즘이 메트릭값으로써 사용하는 인자중 하나입니다. RIPv1, RIPv2에서만 HOP카운트가 인자로써 사용되고, EIGRP나 IGRP에서는 다른 인자가 메트릭값으로 사용됩니다.)
그냥 알아두시라고 말씀드리는 겁니다.(IP주소를 알려드리면 곤란하므로.. 공인IP의 주소는 처음만 보여드리겠습니다.)


본론으로 들어가서..
Static Route란 것은, 경로를 직접 설정했다는 것입니다. 가장 신뢰적인 방법이죠.
명령어 구조는 다음과 같습니다.

ip route [목적지IP의 네트워크 이름] [목적지ip의 브로트캐스팅] [넥스트홉]


목적지ip의 네트워크 이름과 목적지ip의 브로드캐스팅주소를 함께 써줘야만 합니다. 네트워크가 서브넷팅 되어 있을경우를 대비하는 것이지요.. 넥스트 홉이란, 데이터를 내보낼 주소입니다..

Static route의 경우, 중간에 5개의 라우터를 거치게 된다면, 중간의 라우터는 데이터를 받아서 static route에 설정된 대로 다음 홉으로 주기만 하지요. 물론, 5개의 라우터에 모두 설정을 해줘야만 합니다. 또한, 데이터가 갔다가 다시 돌아오는 경로도 같이 설정해줘야 하지요..

메트릭과 신뢰도라는 개념이 있습니다.
신뢰도는 라우팅 테이블을 구성하는 데이터가 얼마나 정확하느냐..라는 개념이군요.
자동으로 라우팅 업데이트를 하는 다른 프토토콜들은 신뢰도의 숫자가 더 높습니다.
당연히 숫자가 높을수록 신뢰도가 낮은것이고요.. Static Route보다 신뢰도가 높은 것은
직접접속하는 경우인 C인경우 하나밖에 없습니다.(이 경우, 신뢰도는 0입니다.)

메트릭(metric)이란, 경로의 신뢰도가 같을 경우, 이 값이 낮을수록 경로선출시 우대를 받는다..는 개념이군요.


간단히 정리해 보겠습니다.


1. 명령어 구조 : ip route [목적지IP의 네트워크 이름] [목적지ip의 브로트캐스팅] [넥스트홉]

2. 데이터 전달법 :

1) 넥스트 홉이 중간  경유지라면 중간 경유지 라우터에서도 설정을 해줘야만 한다.
2) 출발지에서 넥스트홉으로 목적지 ip의 네트워크 이름과 목적지ip의 브로드캐스팅을 가지고 넥스트 홉으로 나간다. 넥스트을 가진 라우터에서는 같은 방법으로 넥스트홉으로 데이터를 내보낸다. 마지막에 목적지ip의 네트워크 이름을 가진 라우터에 도착하면 데이터가 해당 ip로 전달된다.
3) 같은방법으로 응답을 해야하기에 반대방향으로도 모든 라우터에 설정을 해준다.

3. 특징 :

1) 유니캐스트이다.
2) 루프백일 경우에도 설정해준다.
3) 신뢰도는1이다.(신뢰도는 낮을수록 좋으며, dynamic 라우팅 프로토콜에서는 점점 커집니다.)
4) 넥스트홉은 인터페이스로도 설정할수 있다.(정확하게 ip주소를 추천합니다.)

4. 장점 : 높은 신뢰도

5. 단점 : 대규모 네트워크와 네트워크 변화가 많은 환경에서는 비효율적이다.



이런 경우가 있지요..
일치하는 경로가 없을경우, 기본적으로 데이터를 전송해야할 주소가 필요합니다..
이 경우에는 정적 기본경로(Static Default Route)를 설정해주면 됩니다.
명령어 구조는 다음과 같습니다.

ip route 0.0.0.0 0.0.0.0 [넥스트홉]


네트워크테이블을 참조한 다음에, 목적지 경로가 없다면, 맨 마지막에 참조하는 경로지요.
랑루팅 경로 코드 옆에 '*'가 표시됩니다.
모든 경우에 있어서, 기본적으로 셋팅한 경로가 우선시 됩니다.^^

이젠 사진을 보도록 하지요..
모든 경로에 대해서 static route를 설정한 것입니다.

R1에서의 셋팅입니다.
목적지가 R2인에 있는경로가 다 포함되었군요..
=====================================================================
R1(config)#ip route 37.37.2.0 255.255.255.0 37.37.12.2
R1(config)#ip route 37.37.23.0 255.255.255.0 37.37..12.2
                                                   ^
% Invalid input detected at '^' marker.

R1(config)#ip route 37.37.23.0 255.255.255.0 37.37.12.2
=====================================================================
중간에 오타가 하나 났습니다.

목적지가 R3에 있는 경로도 포함되었군요.
=====================================================================
R1(config)#ip route 172.16.3.0 255.255.255.0 37.37.12.2
R1(config)#ip route 37.37.3.0 255.255.255.0 37.37.12.2
=====================================================================
나머지도 보시면 됩니다..

R2에 대한 셋팅입니다.

R3에 대한 셋팅입니다.


기본경로에 대한 셋팅도 보여드릴께요


각각의 셋팅도 보여드릴께요.
핑을 날리는것과 함께 보여드립니다.
!!!!! <--- 이것이 핑이 잘 날라간다는 뜻입니다.
또한, Static Route는 코드가 S입니다. 다음을 보시면 아시겠지요..^^
R1에서의 정보
R1의 정보

R2의 정보
R2의 정보

R3의 정보
R3의 정보


셋팅까지 보여드렸으니..

제가 쓴 셋팅 커맨드와 정보보기 커맨드를 올려드리는것으로써
Static Route학습법에 대한 포스트를 마치겠습니다.

command_static.txt

Static Route학습법 command



후기
점점 어려워 지는군요..
한가지 죄송한 말씀은. 선행해야되는 절차를 무시하고 했습니다.
서브넷팅이니, vlsm이니.. 네트워크 이름이니하는것들.. 먼저 선행해야 하는것인데도 불구하고
그냥 해버렸네요..
다음번엔 그걸 올려볼까 합니다.

시간 나는대로 질문도 받아볼께요..
질문하실것은 없을것 같습니다만. 하하핫..

마지막으로, 모든 자료는 베낀것이 아니라..
제가 직접 강의를 들으면서 기록한것을 토대로 한 것입니다.
제가 직접 기록한 것이므로..
CCL에 나와있는대로 퍼가지 않으실경우
조치를 취할 것입니다..
이런 조치는 조금 더 많은 분들과 함께 자료를 공유하는것을 허락하기 위한 것이며, 트래픽에 의한 계정블록을 방지하기 위한 것입니다.
물론, 제 블로그의 홍보라는 것도 없진 않겠지요..

크리에이티브 커먼즈 라이센스
Creative Commons License
2008/03/03 20:18 2008/03/03 20:18

맨 위로

2. 인터페이스 설정..

2008/02/24 17:38, 글쓴이 prizm
[adsense1]


인터페이스 설정을 해보겠습니다.


인터페이스는 말 그대로 인터페이스를 말하는 것이지요..
이더넷 인터페이스, 시리얼 인터페이스가 그것입니다.
이더넷 인터페이스는 FastEthernet, GigabitEthernet(?)정도가 있구요..
시리얼 인터페이스는 말 그대로 시리얼 인터페이스입니다.

또한, 시스코 IOS를 쓰는 카탈리스트 스위치에서 VLAN을 설정할때도 인터페이스모드에서 하지요.
WAN 구성시, Frame-Relay와 같은 것으로 캡슐화할때도 인터페이스를 사용합니다.(서브인터페이스)

요점은, 인터페이스는 기계장치를 설정하시는것이라고 생각하심 되겠네요.
서브인터페이스에 대해서는 추후에 다시 논하겠습니다.


저는 첫번째 라우터인 R1에서만 설정해봤습니다.
다른라우터에서도 똑같이 하시면 됩니다.

그렇다면 그림을 보며서 하도록 하죠..
제일 처음그림은 제가 임의로 R1의 셋팅을 날린후 초기설정은 수동으로 설정한다고 한 다음에
라우터가 부팅하는 과정입니다. 실제 라우터는 이 과정이 10분씩 걸린다네요..


라우터의 부팅과정에 대해서 간단히 짚고 넘어가도록 하겠습니다.
처음에 라우터의 전원을 올리면, IOS이미지를 찾습니다. FLASH메모리에서 찾게 되지요.
IOS이미지를 찾았으면 이미지를 RAM으로 로딩합니다. 만약 IOS이미지를 불러들이지 못하면
TFTP를 이용해서 다른 서버에서 불러오고요.. 이것도 실패하면 롬에서 mini IOS를 불러들이게 되지요.
IOS이미지를 RAM으로 로딩했다면 이제는 NVRAM에서 설정을 불러오게 됩니다. 그럼 끝이지요..
자세한것은 언젠가 짚고 넘어가게 될 것입니다.

다음 그림은 부팅이 끝난 화면이군요.
이상태에서 enter키를 치면 USER모드로 진입하게 됩니다.
사용자 삽입 이미지

user모드로 진입한 후, 저는 셋팅을 복사해서 붙여넣기 했습니다.
터미널 프로그램이 붙여넣기가 가능하다면 이렇게 붙여넣는것을 추천하더군요..
(실제로 수백줄을 입력해야할때는 메모장에서 작성후 copy&paste를 한다고 합니다.)
paste까지 마친 상태입니다.

사용자 삽입 이미지

잘 보면, no shutdown명령어를 입력한 후에 해당 인터페이스가 활성화 되어 올라왔습니다.
logging synchronous로 리플레시를 했기 때문에 깔끔하게 올라오는 것이지요.
참고로, 지금 환경은 콘솔로 접속한 것입니다.. 그리고 모든 설정이 끝난 화면이지요..

명령어에 대해서 알아보지요..
hostname R1 -> 해당 장치의 이름을 설정하는 것입니다.
int fa0/0 -> interface fastethernet 0/0의 줄임입니다. 이 명령은 인터페이스모드로 들어가는 명령어지요.
ip add 37.37.1.1 255.255.255.0 -> ip address를 설정하는 것입니다. 인터페이스모드로 들어와서 사용해야합니다.
no shutdown -> 장치들이 기본적으로 shutdown되어 있으니 앞에 no를 붙여서 업을 시켜줍시다. 시스코 명령에서는 no를 앞에 붙이면 해당 명령어의 반대명령이 실행됩니다.
exit -> 인터페이스 모드에서 빠져나갑니다.
int s1/0 -> interface serial 1/0인터페이스로 들어갑니다.
ip add 37.37.12.1 255.255.255.0
no shutdown
exit

int lo172 -> interface loopback 172로 들어가는 명령어입니다. loopback은 가상의 인터페이스입니다. 몇개씩 만들어도 좋습니다. 대부분 테스트 용이나, 후에 설명할 라우팅 프로토콜에서 장비의 ID로 쓰이게 됩니다.
ip add 172.16.1.1 255.255.255.0
exit

그렇다면 모든 설정을 NVRAM에 저장해야 합니다. NVRAM은 플래쉬메모리입니다. 비휘발성이지요.
라우터가 작동하고있을때는 모든 작업이 RAM에서 이루어지게 됩니다.
저장하는 명령어는 priv모드에서 [copy running-config start-config]입니다. 줄여서 [copy run start]라고 하지요.

사용자 삽입 이미지

파일 이름을 요구하는데. 그냥 엔터치세요.. 라우터에서 파일명이 왜 필요하겠습니까??
그냥 알아서 하라고 하면 되지요..

마지막으로..
IP주소를 넣을때는 정확히 입력해야합니다. 그리고 서브넷 마스크도 함부로 입력해서는 안되겠지요.
IP주소 낭비를 방지하기 위해서 subneting, vlsm을 이용해서 ip대역을 쪼개서 사용한답니다.

오늘은 여기까지 하겠습니다.
이것도 은근히 힘드네요.. 뭔가를 계속해서 올린다는것이..
640-802 덤프 해설이라도 올려볼까요??
좋아들 하시려나..

기본설정 + 인터페이스 설정 명령어도 올려드립니다..
많이들 사용해 주세요^^


크리에이티브 커먼즈 라이센스
Creative Commons License
2008/02/24 17:38 2008/02/24 17:38

맨 위로

CCNA합격!!

2008/02/24 13:54, 글쓴이 prizm
그간 빡시게 덤프 & 교재 보면서 공부했는데..

어제 아픈몹 끌고가서 시험본 결과..
합격이군요!!

턱걸이라도 합격은 합격입니다!!^^

인증샷..
인증샷

거기서 프린트 할때부터 약간 비뚤어지게 프린트가 되어있네요..
이건 단지확인서(성적)이고..
일주일후에 메일 오면 그걸로 cisco.com에 가입하면
2달안에 자격증이 온다고 합니다...

...
일단은 ccna자격을 취득했군요..


네트워크 구성, WLAN의 구성과 선택(아마도 wan이겠군요.), 보안문제와 네트워크의 일반적인 문제해결은 100%군요..

NAT와 ACL, WAN링크는... 쥐약입니다.ㅡㅠ;;
NAT와 ACL은.. NAT는 잘 아실테고.. ACL은 필터링 하는것입니다..
라우터에서 특정 IP대역(or특정 IP)에 대해서 필터링을 할수 있는 그런 것이지요..


아뭏튼.. 기분은 좋군요^^
허무하다는 생각은 들지 않았습니다..
크리에이티브 커먼즈 라이센스
Creative Commons License
2008/02/24 13:54 2008/02/24 13:54

맨 위로

1. 라우터의 기본셋팅(console, aux, telnet설정까지.)

2008/02/16 13:46, 글쓴이 prizm
[adsense1]



라우터라 함은 일종의 컴퓨터이지요.
PC에 해당하는 메모리, 하드디스크, CPU를 모두 가지고 있다고 보면 됩니다. 그리고 네트워크에서의 데이터 전송과 경로설정만을 주로 하는 컴퓨터라고 보시면 됩니다.

위 그림은 CCNA에서 사용한 실습환경의 IOS이미지 정보입니다.. 실습환경이 실제 라우터랑 99%가 같게 되어 있습니다. 단지, 케이블 연결은 바꿀수가 없다.. 정도겠죠..
CPU가 100MHz군요.. 특수목적형 CPU는 컴퓨터의 CPU와는 다르게 속도가 빠르지 않아도 제성능을 낼 수 있답니다.

..지금부터는 라우팅 셋팅법에 대해서 논해보겠습니다.
우선, 제가 공부하는 라우팅의 개념도를 알아보겠습니다.
사용자 삽입 이미지
라우터1번
루프백(Loopback) : 172.168.1.1 255.255.255.0
Serial 1/0 : 37.37.12.1 255.255.255.0
FastEthernet 0/0 : 37.37.1.1. 255.255.255.0

라우터2번
Serial 1/0 : 37.37.12.2 255.255.255.0
Serial 1/1 : 37.37.23.2 255.255.255.0
FastEthernet 0/0 : 37.37.2.1. 255.255.255.0

라우터3번
루프백(Loopback) : 172.168.3.1 255.255.255.0
Serial 1/0 : 37.37.23.3 255.255.255.0
FastEthernet 0/0 : 37.37.3.1. 255.255.255.0

각 라우터의 FastEthernet 0/0에는 172.168.[라우터번호].1~172.168.[라우터번호].254까지 PC가 할당되어 있는 상태입니다..(가상 시뮬레이팅으로 돌리는 것입니다..)

처음 라우팅을 부팅하거나(or 시뮬레이팅을 실행하거나)하면 초기설정이 없다고 하면서 자동설정을 하는지에 대한 선택이나옵니다. 자동설정이 아닌 수동설정이므로 no를 치시고 엔터.. 이후에 자동인스톨을 하지 않느니 하는것이 나오면 yes를 쳐주세요..

그러면 리눅스처럼 각종 인터페이스에 대한 up/down같은게 주욱 나오고. 마지막에 [....cold start]라고 나오게 되면.. 한번더 엔터키를 쳐주시면 됩니다..
지금부터가 진짜 시작이군요..!


사용자 삽입 이미지


 위 그림은 모든 부팅이 다 끝난 상태입니다. 저는 미리 셋팅을 해놓아서 비밀번호를 2번 입력했습니다. 위에서 보면, Router>라고 나와 있습니다. 이 상태가 User Mode입니다. 기본 시스템 정보 확인, 기본테스트 정도만 가능합니다. 라우터의 설정을 바꾸는 명렁어나, 중요하나 내용을 보여주는 정보확인은 불가능합니다. User Mode에서 [enable]라는 명령어를 입력하면 Router # 라고 변하는군요. Privilege Exec Mode, 즉  관리자 모드라고 합니다. 기본적으로 정보를 보거나, NVRAM에 데이터를 저장 or 저장된 데이터의 삭제등이 가능합니다. 그러나 아직도 라우터 설정은 불가능 하군요..
관리자 모드에서 사용 가능한 명령어는 다음과같습니다.

'show' 명령어로 정적 정보 확인
'show + 명령어(장치이름 등)'으로 해당 장치의 정적 정보 확인
'show ?'으로 도움말 확인가능
'debug'명령어로 동적 정보 확인
'copy'명령어로 저장
'erase'명령어로 삭제
'ping'명령어로 ip 데이터 도달 가능성 확인
'telnet'명령어로 원격 접속 가능
'reload'명령어로 라우터를 리셋(제가 사용하는 시뮬레이팅 프로그램에서는 이명령어는 안먹힙니다. 그러나 실제 장비에서는 작동하는 명령어입니다.)

관리자 모드에서 configure terminal명령어를 입력하면 Router(Config)#라고 나오는 군요. [Global Configuration Mode] 설정 모드라고 합니다. 라우터의 설정이 시작되는 모드로써, 지금부터가 진짜 셋팅의 시작입니다.

마지막을 config-if) or config-sub)같은 하위설정모드가 있군요.. line(터미널, 텔넷설정)이나 interface설정, router모드(routing 설정)등 여러가지가 있습니다.

제가 쓰는 터미널 프로그램은 Secure CRT5.0 입니다. 메모장에 복사해서 붙여넣기가 되는군요.
라우터 3개에 공통적으로 들어가는 command에 대해서 알아보지요.

enable  <- user모드에서 priv모드로 들어가는 명령어 입니다. 저는 이명령 후에 두번째 패스워드를 입력했지요
conf t   <- configure terminal의 줄임말입니다. 시스코 장비에서는 이런식의 축약이 가능합니다.
no ip domain-lookup  <- 실수로 오타가 났을때.. 그 오타를 서버 주소로 인식하게 하지 않는 명령어 입  니다. 예를들어 no ip doamin-lookup이라고 했을때 [no ip doamin-lookup]라는 주소를 찾게 되지요.
line con 0   <- line console 0의 줄임말입니다. 콘솔포트를 이용한 콘솔접속터미널의 설정으로 들어가는군요.
pass ciscocon  <-password ciscocon의 약자입니다. ciscocon은 콘솔접속시의 패스워드입니다.
login   <- 로그인을 하려면 필요하다고 하더군요.
exec-time 0 0  <- 주로 작업하는 곳이 콘솔이기 때문에 콘솔모드에서 작업관련 설정을 해야합니다. 이것은 어느정도 시간이 지나면 user모드로 빠져나가지 않도록 하는 명령어지요.0 0 을 바꿀수도 있습니다만. 자세한것은 직접 해보시길 바랍니다.
logging syn  <- 콘솔모드에서 작업할때, 로그메세지 출력이있습니다. 그때 자동 줄바꿈을 해주는 명령어지요.
exit <- 설정모드 나갑니다.
line aux 0  <- aux에서의 작업 설정입니다.
pass ciscoaux
login
exit
line vty 0 4
  <- 텔넷에서의 작업 설정입니다. 텔넷은 5개까지 접속가능한데. 장비에서는 항상 0부터 시작하기대문에 0 4를 입력한 것입니다.
pass ciscotel
login
exit
enable secret cisco  <- enable명령으로 priv모드로 진입할때의 암호설정입니다. secret는 암호알파벳 자체를 암호화 해 놓는 것입니다. 바로 다음의 enable password명령어보다 우선합니다.
enable password ciscofan  <-enable secret와 같은 기능이나, 알파벳이 암호화 되어 있지 않습니다.

때에 따라서는 위의 명령어가 먹히지 않는 경우도 있습니다. 이는 장비 안에 CISCO IOS버전이 틀려서 그렇더군요.  인터페이스 설정은 다음으로 미룰까 합니다.. 다음번 포스트는 아마도 ccna시험을 보고 난 후에 올라오게 되겠군요..

저는 인터페이스까지 다 설정했지만..
혹시나 몰라서 show running-config명령어를 이용해서 실행되고 있는 라우터의 정보를 긁어와서 텍스트 파일로 올려드리겠습니다. !는 엔터키를 쳤다는 것을 의미합니다.
running_conf.txt

Running-Config내용.

그리고..
시험 잘 볼수 있도록 힘을주세요..
덤프에서 51문제중에 28개 맞았습니다.ㅡㅠ;

마지막으로..  위의 명령어는 텍스트 파일로 올려드리겠습니다.
크리에이티브 커먼즈 라이센스
Creative Commons License
2008/02/16 13:46 2008/02/16 13:46

맨 위로

동영상 테스트

2008/02/14 20:33, 글쓴이 prizm
[adsense1]

secure CRT 5.0에서 작업하는것을 snag it으로 캡쳐해서 mncast로 업로드 했습니다..

잘 보이시면 이걸로 해보려구요...

붙여넣기한 것은 다음과 같습니다.

------------------
enable
conf t
no ip domain-lookup
line console 0
password ciscocon
login
exec-timeout 0 0
logging synchronous
exit
line aux 0
password ciscoaux
login
exit
line vty 0 4
password ciscotel
login
exit
enable secret cisco
enable password ciscofan
---------------------
host R3
int fa0/0
ip add 37.37.3.1 255.255.255.0
no shutdown
exit
int s1/1
ip add 37.37.23.3 255.255.255.0
no shutdown
exit
int lo172
ip add 172.16.3.1 255.255.255.0
exit
--------------------





잘 않보이는군요..
다른 방법을 생각해야 할것 같습니다.
크리에이티브 커먼즈 라이센스
Creative Commons License
2008/02/14 20:33 2008/02/14 20:33

맨 위로

깊은 고민..

2008/02/14 14:26, 글쓴이 prizm

[adsense1]

CCNA를 공부하면서..
조금이나마 알고 있는걸 공유하고자 강의를 올려본다 난리를 쳤는데요..


...
작업한 것을..
어떻게 보여드려야 잘했다고 소문날까요??
그냥 설명하나에 캡쳐하나 이렇게 할까요??
보기에 더 힘드실텐데..

동영상으로 캡쳐해서 mncast같은데 올린다음에 링크떠올까요??
무작정 넘어가는 것이고, mncast자체도 해상도가 그리 좋은것이 아니라서요..
secure crt6.0에 나오는 것을 캡쳐해야하는데 다른 프로그램으로 하면 분명히..
UCC사이트에 올라갈때의 화질저하로 보시기 힘드실 겁니다.

그냥 동영상을 올리는 방법도 있네요.
저작권 그런거 다 필요없지요?? 제가 만드는 것이니까요..
그런데.. 지금 블로그 일일 트래픽이 500MByte입니다..//

PDF로 하기에는 조금 성의없어 보이구요..


우선,
제일 처음 올라갈것은 실습환경 기본셋팅 + 실습환경 설명 + 정적라우팅 설정법입니다..
이거 이후에 RIPv1, RIPv2가 되겠네요.. 3번째는 EIGRP구요.. 4번째는 OSPF, 5번째는 ACL정도가 되겠군요.

중요한건 뭔가를 만드는것도 힘들다는것..
언젠간 포스트에 올라가겠죠..

그리고, 위에 질문...
내공이 충만하신 고수분들께 감이 여쭙게 되네요...

크리에이티브 커먼즈 라이센스
Creative Commons License
2008/02/14 14:26 2008/02/14 14:26

맨 위로

다음에 취득할 자격증..

2007/08/09 17:38, 글쓴이 prizm
[adsense1]

1. 현재 공부중인 정보기기운용기능사
2. 역시 술먹고 머리싸매며 타자쳐서 떨어진 워드 1급 실기..0-_-;;
3. 네트워크관리사
4. CCNA(시스코 어쩌구저쩌구..)....


sun이나 ms쪽은 정말 힘들더군요..
리눅스 마스터도..
.....
..


가능할까요??
크리에이티브 커먼즈 라이센스
Creative Commons License
2007/08/09 17:38 2007/08/09 17:38

맨 위로